Windows Installer

This plug-in provided command checks for or installs the Windows Installer runtime on the target system.

Check for Runtime

Select this option to check for the presence of the runtime, and not install it.

Install Runtime

Select this option to install the runtime if it is not already present.

Windows Installer 2.0

Select this option to install Windows Installer version 2.0. Windows Installer 2.0 is the last version of Windows Installer that is installable on all 32 bit Windows operating systems - from Windows 95 to Server 2003.

Windows Installer 3.0 (NT kernels only)

Select this option to install Windows Installer version 3.0. Windows Installer 3.0 may only be installed on Windows 2000, XP, and 2003. Windows versions based on the 9X kernels (Windows 95, 98, ME) do not support Windows Installer 3.0. In addition, Windows NT 4.0 does not support Windows Installer 3.0.

If setup is running on a system with a 9X kernel, then for both runtime checks and runtime installations, the plug-in will assume version 2.0 of Windows Installer instead (even if version 3.0 was specified). The reason for this behavior is that setups which require Windows Installer 3.0 on Windows NT based operating systems work well with Windows Installer 2.0 on Windows 9X based operating systems.

However, if setup is running on a system with Windows NT 4.0 installed, the plug-in does not make this assumption. The reason for this behavior is that setups which require Windows Installer 3.0 will fail on Windows NT 4.0 unless it is available. Since Windows Installer 3.0 can never be installed on Windows NT 4.0, the plug-in will always fail and correctly report this failure state.

The above plug-in logic helps you keep your setup script simple when installing third party runtimes that require Windows Installer 3.0 (such as .NET Framework 2.0). Simply select the Windows Installer 3.0 option in your setup script, and the plug-in will correctly detect/install v3.0 on systems that require it (Windows NT kernels), and it will correctly detect/install v2.0 on systems that do not require v3.0 (Windows 9X kernels).

Windows Installer 3.1 (NT kernels only)

Select this option to install Windows Installer version 3.1. Windows Installer 3.1 may only be installed on Windows 2000, XP, and 2003. Windows versions based on the 9X kernels (Windows 95, 98, ME) do not support Windows Installer 3.1. In addition, Windows NT 4.0 does not support Windows Installer 3.1.

If setup is running on a system with a 9X kernel, then for both runtime checks and runtime installations, the plug-in will assume version 2.0 of Windows Installer instead (even if version 3.1 was specified). The reason for this behavior is that setups which require Windows Installer 3.1 on Windows NT based operating systems work well with Windows Installer 2.0 on Windows 9X based operating systems.

However, if setup is running on a system with Windows NT 4.0 installed, the plug-in does not make this assumption. The reason for this behavior is that setups which require Windows Installer 3.1 will fail on Windows NT 4.0 unless it is available. Since Windows Installer 3.1 can never be installed on Windows NT 4.0, the plug-in will always fail and correctly report this failure state.

The above plug-in logic helps you keep your setup script simple when installing third party runtimes that require Windows Installer 3.1 (such as .NET Framework 2.0). Simply select the Windows Installer 3.1 option in your setup script, and the plug-in will correctly detect/install v3.1 on systems that require it (Windows NT kernels), and it will correctly detect/install v2.0 on systems that do not require v3.1 (Windows 9X kernels).

Return result in variable

If you specify a previously defined variable in this field, it will hold framework information as follows:

 Warning

 Notes


Copyright© 1996-2013 InstallAware Software. All rights reserved.