Search found 32 matches

by erich.einfalt
Wed Nov 09, 2016 6:51 pm
Forum: Technical Support
Topic: Please build your project before running without debugging
Replies: 15
Views: 2212

Re: Please build your project before running without debugging

Using some string literal as the project output name successfully allows debugging and running from the IDE.

Thanks.
by erich.einfalt
Wed Nov 09, 2016 6:41 pm
Forum: Technical Support
Topic: Please build your project before running without debugging
Replies: 15
Views: 2212

Re: Please build your project before running without debugging

Ohhhhh! The "build" used by the Run From IDE actions don't resolve the compiler variables, it uses the value in the project output name box as a string literal for the IDE "build", right? I'll try using some string literal as the project output name temporarily while debugging an...
by erich.einfalt
Wed Nov 09, 2016 11:54 am
Forum: Technical Support
Topic: Please build your project before running without debugging
Replies: 15
Views: 2212

Re: Please build your project before running without debugging

Thanks for looking at it but the compiler variables you listed as being the problem (#TITLE#_#OUTPUT_FILENAME_SUBTYPE##ROLE#_v#DISPVERSION#-#AUTOBUILDNUM#) all have default definitions (see screen caps attached) NOTE: According to IA documentation, #TITLE# is an IA Pre-Defined compiler variable set ...
by erich.einfalt
Tue Nov 01, 2016 6:41 pm
Forum: Technical Support
Topic: Please build your project before running without debugging
Replies: 15
Views: 2212

Re: Please build your project before running without debugging

Sorry for the delayed reply. Management requires that all sensitive information in our source files and scripts be 'sanitized' if they are sent out of house and since my last post I have had other priorities assigned of late. I now have a management approved, sanitized version of the installer proje...
by erich.einfalt
Fri Jul 29, 2016 12:13 pm
Forum: Technical Support
Topic: Please build your project before running without debugging
Replies: 15
Views: 2212

Re: Please build your project before running without debugging

Did you mean the .mpr file or the entire project folder and its contents?
by erich.einfalt
Thu Jul 28, 2016 1:56 pm
Forum: Technical Support
Topic: Cannot uncheck Restart now
Replies: 1
Views: 553

Cannot uncheck Restart now

The "Restart now" checkbox in the Finish dialog does not change state when it is clicked. There *is* a momentary flicker which would imply that the checkbox control is receiving the mouse click event but it will not change state. Below are screen grabs of the settings in the dialog editor ...
by erich.einfalt
Tue Jun 28, 2016 4:37 pm
Forum: Technical Support
Topic: Please build your project before running without debugging
Replies: 15
Views: 2212

Re: Please build your project before running without debugging

Sorry for the late followup. The Build Settings for this project is set to Compressed Single Self Installing EXE. The rest of the settings are as previously shown.
by erich.einfalt
Tue May 31, 2016 1:00 am
Forum: Technical Support
Topic: Please build your project before running without debugging
Replies: 15
Views: 2212

Re: Please build your project before running without debugging

Q: "are you sure that the compressed EXE has been effectively generated?" A: Yes, because I can run the finished compressed single .exe from the #PROJDIR#\Release\Single folder and it runs correctly. Q: "Are you sure that those you entered effectively match with the build mode you use...
by erich.einfalt
Fri May 27, 2016 4:00 pm
Forum: Technical Support
Topic: Please build your project before running without debugging
Replies: 15
Views: 2212

Please build your project before running without debugging

X3 Studio Admin Edition, Update 20.11, Win8.1 I build the installer project (Single EXE) successfully, and now, after I have begun dual signing the components using the IA Build Events according to InstallAware's published instructions, I get this message every time I click the Green Arrow on the ID...
by erich.einfalt
Wed Mar 16, 2016 1:34 am
Forum: Plug-In Development
Topic: C# .NET plugin fails when dragging it to an IA script
Replies: 14
Views: 5656

Re: C# .NET plugin fails when dragging it to an IA script

Disregard my post dated Tue Mar 15, 2016 10:52 pm

There was an errant namespace entry in the runtime bridge .ini file.

The plug-in is now working as expected.

Thanks for all your help.
by erich.einfalt
Wed Mar 16, 2016 12:52 am
Forum: Plug-In Development
Topic: C# .NET plugin fails when dragging it to an IA script
Replies: 14
Views: 5656

Re: C# .NET plugin fails when dragging it to an IA script

I added logging functionality to capture (to a file in the User's %TEMP% folder) the arguments passed into the public methods of the Accessory project at the beginning and end of each method (so I can capture and compare the changes made to those arguments that are passed in by reference). What I fo...
by erich.einfalt
Mon Mar 14, 2016 1:49 pm
Forum: Plug-In Development
Topic: C# .NET plugin fails when dragging it to an IA script
Replies: 14
Views: 5656

Re: C# .NET plugin fails when dragging it to an IA script

Thanks for tearing apart your plug-in and finding this. I, too, found the trailing double-quote artifact in my plug-in but have opted to change my plug-in's behavior because the amount of data expected to be returned in the IA output variable is too large to display in a MessageBox and so I have no ...
by erich.einfalt
Fri Mar 04, 2016 12:24 pm
Forum: Plug-In Development
Topic: C# .NET plugin fails when dragging it to an IA script
Replies: 14
Views: 5656

Re: C# .NET plugin fails when dragging it to an IA script

Well, this is interesting -- 2 Items of Note: 1. bokkie replied: " ... if you'd like your plugin to receive the name of the variable instead of having to enter it in the plugin's variable name textbox. Is that what you'd like to do? If it is, then unfortunately it's not possible to pass the var...
by erich.einfalt
Fri Mar 04, 2016 10:52 am
Forum: Plug-In Development
Topic: C# .NET plugin fails when dragging it to an IA script
Replies: 14
Views: 5656

Re: C# .NET plugin fails when dragging it to an IA script

Thanks for the quick response. We are using VS2013 Professional but we're about to move to VS2015.
by erich.einfalt
Wed Mar 02, 2016 4:06 pm
Forum: Plug-In Development
Topic: C# .NET plugin fails when dragging it to an IA script
Replies: 14
Views: 5656

Re: C# .NET plugin fails when dragging it to an IA script

The MAC addresses .NET plug-in project you posted provided necessary insight into some of what I can only describe as 'vagaries' in IA Plug-In development using .NET. Thank you for that. However, none of the sample projects I have found for writing IA plug-ins (regardless of language) seem to includ...

Go to advanced search