Search found 20 matches

by mehran
Thu Aug 16, 2018 2:16 pm
Forum: Technical Support
Topic: Running an application within the installer causes issue in maintenance mode
Replies: 0
Views: 922

Running an application within the installer causes issue in maintenance mode

Hi guys, I run a .exe file towards the end of my application, and it works fine when I do fresh install. But when I do a maintenance install after that (using change option in control panel), after my installer runs that executable and completes, user cannot open any installer from programs and feat...
by mehran
Sun Apr 15, 2018 1:16 am
Forum: Technical Support
Topic: Uninstalling old version in Native Engine mode.
Replies: 0
Views: 1037

Uninstalling old version in Native Engine mode.

Hi there. We use Native Engine and I know that we should use Run Command to uninstall a product instead of using (Un)InstallMSI command in Native Engine. The problem we have is when we use (Un)InstallMSI command it displays details of uninstalling the product in the progress dialog, but when we use ...
by mehran
Thu Apr 12, 2018 12:11 pm
Forum: Technical Support
Topic: (Un)Install MSI Setup
Replies: 6
Views: 2214

Re: (Un)Install MSI Setup

Hi there. We use Native Engine and I know that we should use Run Command to uninstall a product instead of using (Un)InstallMSI command in Native Engine. The problem we have is when we use (Un)InstallMSI command it displays details of uninstalling the product in the progress dialog, but when we use ...
by mehran
Fri Apr 06, 2018 12:31 pm
Forum: Technical Support
Topic: Branding Removal in InstallAware 11
Replies: 8
Views: 12783

Re: Branding Removal in InstallAware 11

I understand that at the point that this dialog is being displayed, the project does not have access to variables, but it should be possible to use compiler variables here. I tried using compiler variables, but they don't work either. Is it possible for you to add support for compiler variables in t...
by mehran
Fri Apr 06, 2018 8:34 am
Forum: Technical Support
Topic: Branding Removal in InstallAware 11
Replies: 8
Views: 12783

Re: Branding Removal in InstallAware 11

Hi guys, As you know Shared Strings are not project specific. I tried using variables in the strings to make them work for each project, but it does not seem to work: "$TITLE$ is preparing the InstallAware Wizard..." Is there a way to make the text in the initialization dialog project spec...
by mehran
Thu Jan 01, 2015 8:16 am
Forum: Technical Support
Topic: Extracting multi-part 7zip archive
Replies: 1
Views: 1939

Extracting multi-part 7zip archive

Hi guys, We have a multi-part 7zip archive that we need to extract during install. (The file names are VS2010ISO.7z.001, VS2010ISO.7z.002 and VS2010ISO.7z.003) In InstallAware 18, we simply called "Extract 7ip Archive" and passed the first part of the archive (VS2010ISO.7z.001) and the ful...
by mehran
Tue Nov 26, 2013 3:09 pm
Forum: Technical Support
Topic: InstallAware 17 Upgrade Compression Issue
Replies: 7
Views: 5137

Re: InstallAware 17 Upgrade Compression Issue

Hi there, We had same problem with installer size after upgrading to version 18 (from version 15). Our installer was 83MB before upgrading and it is 133MB after upgrading to IA 18. I have done some observation on this issue and I hope it can help you find a solution for us. We always do a Web deploy...
by mehran
Thu May 30, 2013 11:45 am
Forum: Technical Support
Topic: Product Version property only keeps ten characters
Replies: 13
Views: 6362

Re: Product Version property only keeps ten characters

Hi Francesco, First of all thank you for your fast reply. But I have some other installer files on my computer that have Product Versions in 1.2.3.4 format (four segments). I have attached one of them. Even if this was the case and Product Version accepted only three segments, It should have truncat...
by mehran
Thu May 30, 2013 9:01 am
Forum: Technical Support
Topic: Product Version property only keeps ten characters
Replies: 13
Views: 6362

Product Version property only keeps ten characters

Hi There, When We set the Product Version property to a string that has more than 10 characters, after building installer, the setup.exe file only shows first 10 characters of Product Version. For example when I set the Product Version to 7.4.0.17067, when I right click on generated Setup.exe file a...
by mehran
Thu Jul 10, 2008 1:48 pm
Forum: Technical Support
Topic: Edit INI - when user doesn't have access to ini file
Replies: 0
Views: 2716

Edit INI - when user doesn't have access to ini file

Hi. I am using Edit INI to change a value in an Ini file, but I don't want it to cancel installation if the user doesn't have access to the ini file. Currently when the installation wants to edit Ini file and it can't it rolls back all of the installation, but I want it to show a warning and continu...
by mehran
Mon May 12, 2008 2:35 pm
Forum: Technical Support
Topic: Write SQL results to s file
Replies: 6
Views: 4646

Installaware doesn't supprot this directly. You have to use bcp.exe tool which exists in binn directory of SQL Server (if you are using SQL Server). you should use "Run Program" and call bcp.exe, and provide commands for it. (see microsoft website for details about this command) Mehran Bal...
by mehran
Thu May 08, 2008 4:39 pm
Forum: Technical Support
Topic: Web Update, Deletes my ini file
Replies: 2
Views: 2786

I also tried keep every install time settings persistent (set persistent variable...) but it doesn't work either, because before installing update "uninstall previous version" happens and deletes all persistent variables!
please help me.
by mehran
Thu May 08, 2008 3:20 pm
Forum: Technical Support
Topic: Web Update, Deletes my ini file
Replies: 2
Views: 2786

Web Update, Deletes my ini file

I have built a setup with web update. My application includes an .ini file, and keeps some settings in that (some of them are being set during installation, and some by my own EXE file). When I do a web update, it install everything, it deletes everything in the installation folder (including my .in...
by mehran
Wed May 07, 2008 12:49 pm
Forum: Technical Support
Topic: Web Update - mia.lib not found
Replies: 1
Views: 5668

Web Update - mia.lib not found

Hi I am evaluating InstallAware 7. I finally found how to use web update, but something is wrong. here is the scenario: -I created a version (1.0.0) of my software and installed it on a computer. -I created a newer version (1.0.1) and uploadet to website in the right place, I also uploadet updates.i...
by mehran
Mon May 05, 2008 11:28 am
Forum: Technical Support
Topic: Sending a _PRINTER_INFO_2A to a dll
Replies: 2
Views: 2997

Thank you

Thank you for the answer, I'm gonna try this.

Go to advanced search