Command Line Build NOT Building with Elevated UAC (requireAdministrator)

Got a problem you cannot solve? Try here.
Posts: 1
Joined: Fri Dec 03, 2021 3:52 pm

Command Line Build NOT Building with Elevated UAC (requireAdministrator)

Postby yol1ana » Fri Dec 03, 2021 4:00 pm

ETAS uses InstallAware Studio Admin X13 to create custom packages of our software for special use cases for our customers. Our EXE''s need to be built with elevated UAC permissions (requireAdministrator) in order to work correctly on customer machines. We use miabuild.exe via command line to automatically create these builds and out of nowhere the elevated permission stopped working when calling miabuild.exe via command line but DOES work when built directly in the InstallAware IDE..

Has anyone else experienced this before? Calling miabuild.exe via command line with our project parameters worked for this up until yesterday is when I noticed the builds weren't being made with elevated UAC. As I said, I can click "Build" in the IDE with all project parameters remaining the same and it works as expected.

Any help on resolving this would be greatly appreciated!

Site Admin
Posts: 5243
Joined: Sun Aug 22, 2010 4:28 am

Re: Command Line Build NOT Building with Elevated UAC (requireAdministrator)

Postby FrancescoT » Mon Dec 06, 2021 11:29 am

I suppose that by mistake, you are not invoking the same identical project file (*.mpr) when building from command line.

From Miabuild there is no way to override or to set the UAC settings for the generated package. The UAC settings are stored with the project file itself (*.mpr). Due of this, to produce from command line a setup package with different UAC settings, you forcebly need to invoke a specific project file where these have been already defined.

Hope this helps you.
Francesco Toscano
InstallAware Software

White Papers (HowTos) - ... papers.htm
Publications -
InstallAware Help -F1 anywhere in the InstallAware IDE

Return to “Technical Support”

Who is online

Users browsing this forum: Google [Bot] and 19 guests