Copy Local Files fails

Got a problem you cannot solve? Try here.
tosch
Posts: 62
Joined: Thu May 27, 2010 8:44 am

Copy Local Files fails

Postby tosch » Wed Dec 01, 2021 3:07 am

In my setup script I copy the installation from where it is executed to a folder using 'Copy Local Files'.

This always used to work but always fails now. How can I find out why it fails?
The installation file is about 110mb big. Could this be a problem?

I'm currently using InstallAware X13/12.18.2020

Thomas

FrancescoT
Site Admin
Posts: 5268
Joined: Sun Aug 22, 2010 4:28 am

Re: Copy Local Files fails

Postby FrancescoT » Thu Dec 02, 2021 3:44 pm

You should provide some more details...othrewise, it's quite difficult to assist you.
Francesco Toscano
InstallAware Software

White Papers (HowTos) - http://www.installaware.com/publication ... papers.htm
Publications - http://www.installaware.com/publications-review.htm
InstallAware Help -F1 anywhere in the InstallAware IDE

tosch
Posts: 62
Joined: Thu May 27, 2010 8:44 am

Re: Copy Local Files fails

Postby tosch » Fri Dec 03, 2021 5:32 am

What details do you want to know?

Native_Engine = True

Thomas

FrancescoT
Site Admin
Posts: 5268
Joined: Sun Aug 22, 2010 4:28 am

Re: Copy Local Files fails

Postby FrancescoT » Fri Dec 03, 2021 2:32 pm

You said that ''Copy Local Files' used to work fine, but suddenly this stopped to work.

But...

- is the same identical build of your setup package (which worked fine untill now) that stopped to work?
- is this a new version (a new build) of your setup package?
- is the problem limited to some specific target machines?
- When is the ''Copy Local Files' invoked during the setup runtime?
- Which kind of files are you copying?
- Where are these stored and where are these should be moved/copied to?
Francesco Toscano
InstallAware Software

White Papers (HowTos) - http://www.installaware.com/publication ... papers.htm
Publications - http://www.installaware.com/publications-review.htm
InstallAware Help -F1 anywhere in the InstallAware IDE

tosch
Posts: 62
Joined: Thu May 27, 2010 8:44 am

Re: Copy Local Files fails

Postby tosch » Mon Dec 06, 2021 3:20 am

1. We made a new build of our setup package using Installaware X13. We moved to X13 for this new version of our software. Before we used Installaware 18 where the CopyLocalFiles always worked.
2. the problem occurs on all systems I have tested.
3. CopyLocalFiles is invoked pretty much at the end of the setup script. After that we only write one registry entry.
4. I am copying the installation itself (setupxxx.exe)
5. the setupxxx.exe is either stored in a folder under %tmp% or can also be stored on a network folder. I want to copy it to either a local folder or a network folder. No combination works for me.
6. the size of setupxxx.exe is about 110MB.
7. When writing a batch file in the setup script to copy the setupxxx.exe and executing it from the setup script it works fine with all combinations of source/target folder.

Hope this helps to figure out what's happening.

Thomas

FrancescoT
Site Admin
Posts: 5268
Joined: Sun Aug 22, 2010 4:28 am

Re: Copy Local Files fails

Postby FrancescoT » Tue Dec 07, 2021 2:49 pm

Can you provide a very [b"]VERY"[/b] minimal project that replicates the issue?
Francesco Toscano
InstallAware Software

White Papers (HowTos) - http://www.installaware.com/publication ... papers.htm
Publications - http://www.installaware.com/publications-review.htm
InstallAware Help -F1 anywhere in the InstallAware IDE

tosch
Posts: 62
Joined: Thu May 27, 2010 8:44 am

Re: Copy Local Files fails

Postby tosch » Mon Dec 13, 2021 3:42 am

I have put together a small sample installation where copy local files fails.
There is a target variable set in line 8 and the copying stuff is from line 259 - 283.

in the meantime I have circumvented the problem by deleting the file in the targetfolder first.

Thomas
Attachments
TestCopy.zip
Sample script
(1.29 MiB) Downloaded 32 times

FrancescoT
Site Admin
Posts: 5268
Joined: Sun Aug 22, 2010 4:28 am

Re: Copy Local Files fails

Postby FrancescoT » Mon Jan 10, 2022 12:17 pm

I finally had a chance to properly test the NATIVE_OVERWRITE matter.

The behaviour of "Install Files" and "Copy/Move Local Files", it's exactly identical and it works as expected.

The overwrite occurs (by default) when the setup is about to overwrite a file with a newer copy (or newer version).
While no overwrite occurs when the installed/copied file is an older copy of target file. ...and this is the correct expected behaviour. Unless you decide to force such behaviour with the use of the "NATIVE_OVERWRITE_OLDER" pre-defined variable (which is generally not recommended).
Francesco Toscano
InstallAware Software

White Papers (HowTos) - http://www.installaware.com/publication ... papers.htm
Publications - http://www.installaware.com/publications-review.htm
InstallAware Help -F1 anywhere in the InstallAware IDE

tosch
Posts: 62
Joined: Thu May 27, 2010 8:44 am

Re: Copy Local Files fails

Postby tosch » Mon Jan 17, 2022 4:34 am

I didn't realise that the setup also has a version information. I can now see why the file did not get overwritten.

Was this behaviour different in version X9 (Build 12.3.2018)? Because I never had a problem there.

Thomas

FrancescoT
Site Admin
Posts: 5268
Joined: Sun Aug 22, 2010 4:28 am

Re: Copy Local Files fails

Postby FrancescoT » Tue Jan 18, 2022 6:56 am

This behaviour was not itroduced recently, and it was the same in X9.

I can only suppose that probably you also used the "NATIVE_OVERWRITE_OLDER".
Francesco Toscano
InstallAware Software

White Papers (HowTos) - http://www.installaware.com/publication ... papers.htm
Publications - http://www.installaware.com/publications-review.htm
InstallAware Help -F1 anywhere in the InstallAware IDE


Return to “Technical Support”

Who is online

Users browsing this forum: No registered users and 13 guests