SQL CE 3.5 SP1 installation does not work with InstallAware X15 H2

Got a problem you cannot solve? Try here.
kaepteniglo
Posts: 16
Joined: Mon Apr 19, 2010 2:15 am
Location: Germany

SQL CE 3.5 SP1 installation does not work with InstallAware X15 H2

Postby kaepteniglo » Thu Jan 19, 2023 6:39 am

Dear InstallAware,

we have several applications which are using SQL CE 3.5 SP1 (x86 / x64).

Last year we had to update to the latest version of InstallAware (X15H2) since you had found a security issue.

After we upgraded to the latest version we created new installer of our application.
Now we are facing issues during the installation.

SQL CE 3.5 SP1 is a pre-requisite of our application and should be installed upfront during the setup.

With an installer created by InstallAware X2 this step works without any issue on the target machines (Win 10 / Win 11).

But when I launch the installer created by InstallAware X15 H2 I receive the information that the installation of SQL CE 3.5 SP1 was not possible and should be done manually.

If I launch the SQL CE installer package, which are included in the setup, by hand the installation of SQL CE works, but not when it was launched from the installer.

We haven't changed anything in our installer script for installing SQL CE 3.5 SP1.

Can you please assist us with this issue?

Regards,

Thomas from PATH MEDICAL GmbH

FrancescoT
Site Admin
Posts: 5326
Joined: Sun Aug 22, 2010 4:28 am

Re: SQL CE 3.5 SP1 installation does not work with InstallAware X15 H2

Postby FrancescoT » Wed Feb 01, 2023 10:13 am

I don't think your issue can be related to the InstallAware upgrade.

I done a quick test and I don't see any issue when installing SQL CE 3.5 pre-requisites. The runtime gets installed as expected.

Probably for some reasons, something went corrupted with your project.
Francesco Toscano
InstallAware Software

White Papers (HowTos) - http://www.installaware.com/publication ... papers.htm
Publications - http://www.installaware.com/publications-review.htm
InstallAware Help -F1 anywhere in the InstallAware IDE


Return to “Technical Support”

Who is online

Users browsing this forum: Google [Bot] and 19 guests