Uncheck the 'Run Now' checkbox...

Got a problem you cannot solve? Try here.
Steve
Posts: 115
Joined: Fri Jun 16, 2006 9:51 pm
Location: Canada eh

Uncheck the 'Run Now' checkbox...

Postby Steve » Wed Aug 26, 2009 7:42 pm

I'm kind of embarassed to be asking this question, as I am sure that the answer is probably staring me in the face, but frustration has set in I can't see the forest for the trees... so, swallowing my pride, here goes...

On the 'Finish' dialog there is a 'Run Now' checkbox.
When I run my compiled installation, the 'Run $Title$ Now' checkbox is always enabled. Enabled appears to be the default mode, however in this case I would like the checkbox default to be 'not checked' (disabled). There is no 'Unchecked' Property Value available for this control (there is only a 'Checked' Property Value available), so obviously that is not the solution. I have the 'Checked' property = 'False' and the 'State' property = 'cbUnchecked', yet when the 'Finish' dialog appears at the conclusion of an install the darned 'Run Now' checkbox is always enabled (checked).
I cannot find any MSI code that is enabling the Run Now checkbox. So what gives?

On all of my previous installs this has never been a issue because the default checkbox enabled behaviour was desired. However now that I need to change this, for the life of me I cannot figure out a way to do it.

Any help is greatly appreciated.
Steve

ChrisN
Posts: 25
Joined: Thu Jul 23, 2009 7:32 am

Postby ChrisN » Thu Aug 27, 2009 7:30 am

Hi Steve.

Insert the following in MSIcode before calling Display Dialog: finish:

Set Variable RUNAPP to FALSE


Best regards.

neillans
Posts: 536
Joined: Sat Nov 04, 2006 6:21 am
Location: Scottish Borders, UK
Contact:

Postby neillans » Thu Aug 27, 2009 3:26 pm

Going to make this post a sticky, as it comes up a lot :)
Andy Neillans

Steve
Posts: 115
Joined: Fri Jun 16, 2006 9:51 pm
Location: Canada eh

Postby Steve » Mon Aug 31, 2009 2:49 pm

Hi Chris,
Worked perfectly!
Thanks very much for your response.

For anyone following this thread I have included the code area affected. The "Set Variable RUNAPP to False" suggested by Chris is located third line down from the top.

Code: Select all

[DEFINE REGION: Finish Setup]
Comment: End of Installation
Set Variable RUNAPP to False
Hide Dialog
Display Dialog: finish, wait for dialog to return (modal)
if Variable SILENT Equals FALSE
  if Variable REBOOTCOMPUTER Equals TRUE
    if Variable SUCCESS Equals REBOOT
      Reboot Computer
    end
  end
  if Variable RUNAPP Equals TRUE
    if Variable REMOVE Equals FALSE
      if Variable SUCCESS Equals COMPLETE
        Comment: TO-DO: Insert command that starts your application here
        Run Program $TARGETDIR$\\myapp.exe
      end
    end
  end
end
END REGION

ParallaxiT
Posts: 32
Joined: Tue Mar 10, 2009 12:10 pm

Thanks for codew

Postby ParallaxiT » Thu Nov 19, 2009 11:40 am

Steve - thanks for posting the code affected. Makes it a lot easier for everyone who is experiencing problems to understand solutions.

Cheers :D

prezmer
Posts: 31
Joined: Wed Jul 23, 2008 8:59 am
Location: Warsaw, Poland

Re: Uncheck the 'Run Now' checkbox...

Postby prezmer » Wed May 19, 2010 3:59 am

Hi,
I went into the same problem, luckily I was able to delete post with exact question. IMO it is not natural to change it inside script. I guess it is the way to extend possibilities of setup customization. I would add a note on Dialogs screen in User Interface branch, something like "dialogs behaviour like "run/restart now" can be configured using MSICode"
best regards
Piotr Rezmer


Return to “Technical Support”

Who is online

Users browsing this forum: No registered users and 14 guests