Dotnet plugin frameworks supported.

Got a problem you cannot solve? Try here.
bokkie
Posts: 767
Joined: Sun Feb 08, 2009 6:30 am

Dotnet plugin frameworks supported.

Postby bokkie » Sat Nov 03, 2012 5:42 am

I was wondering if someone in the IA team could give me some confirmation about the Dotnet plugin frameworks which are supported. At this time, I only have VS 2012 installed. When compiling a plugin I find I can use frameworks up to version 3.5 successfully. The moment I try and use version 4.0 or 4.5, the plugin fails with an error when I drag it onto the MSIcode.

This makes me think the Bridge can't work with frameworks 4.0 and 4.5? If that's the case are there any plans to let it work on 4.0 and higher?
Peter. Smartly dressed, he still resembles an unmade bed.
InstallAware MVP

MaxLogic.eu
Posts: 25
Joined: Sat Oct 08, 2011 2:42 am
Contact:

Re: Dotnet plugin frameworks supported.

Postby MaxLogic.eu » Mon Nov 05, 2012 2:03 am

Dear bokkie,

bokkie wrote:the plugin fails with an error when I drag it onto the MSIcode.


What exactly is the error message? Is your net plug-in called at all, or does the bridge fails prior to loading the net assembly?
Would it be possible for you to send me the source code of you design time plug-in? or at least the net assembly, so I can test it?

with best regards
Pawel
About me:
Pawel Piotrowski is a software developer and a Delphi and C++/C# expert with 15 years of programming experience.
Learn more at http://www.maxlogic.eu

bokkie
Posts: 767
Joined: Sun Feb 08, 2009 6:30 am

Re: Dotnet plugin frameworks supported.

Postby bokkie » Mon Nov 05, 2012 2:33 am

Pawel,

There's no problem right up to 3.5. I then changed the projects to 4.0. I then created a new (empty) IA project and dragged the plugin directly onto the MSIcode. The error message I get is:

"Could not load file or assembly 'file:///C:\Temp/Test123/Test123IDE.dll' or one of its dependencies. This assembly is built by a runtime newer than the currently loaded runtime and cannot be loaded."

That's why I wonder if plugins are okay up to framework 3.5 as it's only 4.0 and 4.5 that tip it over the edge.
Peter. Smartly dressed, he still resembles an unmade bed.
InstallAware MVP

FrancescoT
Site Admin
Posts: 4852
Joined: Sun Aug 22, 2010 4:28 am

Re: Dotnet plugin frameworks supported.

Postby FrancescoT » Fri Nov 09, 2012 11:57 am

Dear bokkie,

let me do a test ... I will be back as soon as possible.

Regards
Francesco Toscano
InstallAware Software Support

White Papers (HowTos) - http://www.installaware.com/publication ... papers.htm
Publications - http://www.installaware.com/publications-review.htm
InstallAware Help -F1 anywhere in the InstallAware IDE

glenharvy
Posts: 145
Joined: Fri Sep 14, 2007 3:53 am

Re: Dotnet plugin frameworks supported.

Postby glenharvy » Fri Jan 05, 2018 6:21 pm

FrancescoT wrote:Dear bokkie,
let me do a test ... I will be back as soon as possible.
Regards


I have spent over a week :cry: trying to get the .Net Bridge working and have discovered that the answer to this question is ....

As at this date, the .Net Bridge will not work with a runtime greater than 3.5 . :o

Glen.


Return to “Technical Support”

Who is online

Users browsing this forum: Bing [Bot], Google [Bot] and 10 guests