Bridge plug-in runtime error.

Interested in developing new plug-ins? Got one to share? Post here!
bokkie
Posts: 767
Joined: Sun Feb 08, 2009 6:30 am

Re: Bridge plug-in runtime error.

Postby bokkie » Tue Oct 02, 2012 1:32 pm

christ23,

Something I'd like you to try: make a copy of the progress.dfm and progress.dfm.miaf with the name MyProgress for example. Open IA and add the dialog to a project. Double-click the MyProgress dialog in the MSIcode window. Use the toolbox and add another progress bar to the dialog. Compare the properties between your new one and the existing one. You'll notice only superficial differences. Save the dialog. Change your code to reference the MyProgress dialog. Build the project and run it. If it works as expected you'll see the original progress bar is updated but not the new one?

Edit the dialog again. Delete the original progress bar leaving only the new one you added. Save the dialog, build the project and run it. Notice now that no updating occurs on the new progress bar. That's how it works on mine. My question is why? If there are only minor differences between the progress bars why did the original one work and not the new one? I've checked all the properties in the dialog and there's nothing I can see that explains why one works and not the other. Maybe you have an idea?

The reason I tried this is I wanted to see if you could create a new dialog and add controls to it without basing the dialog on an existing one. The .dfm file is in binary format so there's no chance of looking in it to see if there's something you might want to include in a new dialog. Providing you always copy the existing progress dialog and leave the progress bar alone you can add new functionality. Right now, I'm puzzled about the progress bar. Does the callback work only on that progress bar and no other? I'll leave it at that and look forward to reading your comments or anyone else who has an interest in how it works.

Francesco, you've been quiet on this for a while so do you have any internal knowledge what might explain it? It's not a red flag issue but something I'd like to add to my understanding of things.

Edit: Another thing I noticed. If I copy-and-paste the progress bar that works and build and run the project, then both progress bars are updated! It really seems there's something about the original progress bar's engine room that accounts for it?
Peter. Smartly dressed, he still resembles an unmade bed.
InstallAware MVP


Return to “Plug-In Development”

Who is online

Users browsing this forum: Google [Bot] and 3 guests