MS SQL Server Connection Issues: Connecting via SMB Port 445

Got a problem you cannot solve? Try here.
tj
Posts: 44
Joined: Tue Nov 04, 2008 9:38 am
Location: Atlanta, GA

MS SQL Server Connection Issues: Connecting via SMB Port 445

Postby tj » Tue Oct 27, 2009 12:40 pm

We have spent a great deal of time troubleshooting connectivity issues with a just a few clients. We ended up using a network sniffer to determine that the MS SQL Server plug-in is connecting via SMB port 445 as opposed to port 1433. We found that these clients have disabled the SMB port 445 for file and print sharing due to security concerns. Thus, we were not able to connect to the database server to setup our application's database.

We are able to get around this by adding HOSTNAME,1433 in the "Server:" field of the plug-in. This appears to force the plug-in to go to the specified port.

You can verify this yourself by disabling the SMB port and attempting to connect with the MS SQL Server plug-in.

To do so follow these instructions:
-Start Registry Editor (Regedit.exe).
-Locate the following key in the registry:
HKLM\\System\\CurrentControlSet\\Services\\NetBT\\Parameters
-In the right-hand side of the window find an option called TransportBindName.
-Double click that value, and then delete the default value, thus giving it a blank value.
-Close the registry editor.

-Reboot your computer.

After rebooting open a command prompt and in it type

netstat -an

See that your computer no longer listens to port 445. You'll find that the connection test now fails unless you specify Server,Port as I mentioned above. You may actually have to specify the IPAddress unless the name still resolves.


I have two points for my post:

- I wanted to make this information available to the community because information like this has been a big help to me via the forum.

- I wanted to know if someone from InstallAware could help us understand why the plug-in would use the SMB port 445 and not 1433 by default?

skierdoc
Posts: 8
Joined: Sun Apr 25, 2010 1:53 pm

Re: MS SQL Server Connection Issues: Connecting via SMB Port

Postby skierdoc » Tue May 04, 2010 7:07 pm

Thank you for this post.

I was having a problem getting the connection to work on a client computer, and forcing Port 1433 as you described solved it.

MichaelNesmith
Posts: 3452
Joined: Thu Dec 22, 2005 7:17 pm
Contact:

Re: MS SQL Server Connection Issues: Connecting via SMB Port

Postby MichaelNesmith » Tue May 04, 2010 7:16 pm

Thank you. Promoting to sticky. I've also advised R&D of the situation, so they can take corrective action.
Michael Nesmith
InstallAware
Home of The Next Generation MSI Installer
Get your free copy today - http://www.installaware.com/

MichaelNesmith
Posts: 3452
Joined: Thu Dec 22, 2005 7:17 pm
Contact:

Re: MS SQL Server Connection Issues: Connecting via SMB Port

Postby MichaelNesmith » Thu May 06, 2010 11:41 pm

This has been made the default port in InstallAware 9 R2. Custom ports are still supported using the syntax you have described.
Michael Nesmith

InstallAware

Home of The Next Generation MSI Installer

Get your free copy today - http://www.installaware.com/

MichaelNesmith
Posts: 3452
Joined: Thu Dec 22, 2005 7:17 pm
Contact:

Re: MS SQL Server Connection Issues: Connecting via SMB Port

Postby MichaelNesmith » Wed May 12, 2010 5:12 pm

For users of InstallAware 9 R2 who are having trouble with the new default implementation, please fall back to the older version attached. Replace the DLL in this folder (a typical path) with the attached one: C:\Program Files\InstallAware\InstallAware 9 R2\Plug-Ins\MS SQL Server

Rebuild your project after downgrading the plug-in DLL file. Do NOT replace files inside an already built output folder as that will have no effect.
Attachments
mMSSQLExec.zip
Previous version of MS SQL Plug-In.
(525.74 KiB) Downloaded 1251 times
Michael Nesmith

InstallAware

Home of The Next Generation MSI Installer

Get your free copy today - http://www.installaware.com/

MichaelNesmith
Posts: 3452
Joined: Thu Dec 22, 2005 7:17 pm
Contact:

Re: MS SQL Server Connection Issues: Connecting via SMB Port

Postby MichaelNesmith » Wed May 12, 2010 5:25 pm

We also have an update on this issue from the component vendor. Their response is as follows:

It seems that you try to connect to an instance of SQL Server that is configured to listen on the Named Pipes server network library only. In this case SQL Server communicates over TCP port 445. To solve the problem, you must enable the TCP port 445.

This behavior is determined by SQL Server and not SDAC. [where SDAC is the name of the component used by InstallAware]

You can find more detailed information about it by the following link:
http://support.microsoft.com/kb/839269


Please feel free to share with us any further findings. Thank you.
Michael Nesmith

InstallAware

Home of The Next Generation MSI Installer

Get your free copy today - http://www.installaware.com/

MichaelNesmith
Posts: 3452
Joined: Thu Dec 22, 2005 7:17 pm
Contact:

Re: MS SQL Server Connection Issues: Connecting via SMB Port

Postby MichaelNesmith » Tue May 25, 2010 7:07 pm

We have had to roll back this change (default connection port of 1433) due to more problems it created than it solved. The latest update to InstallAware 9 R2 (9.08):
www.installaware.com/forum/viewtopic.php?f=2&t=5658

No longer assumes this port as default (although the override described in this thread will continue to work).
Michael Nesmith

InstallAware

Home of The Next Generation MSI Installer

Get your free copy today - http://www.installaware.com/


Return to “Technical Support”

Who is online

Users browsing this forum: Exabot [Bot] and 23 guests