Run .NET Installer Class doesn't work

Got a problem you cannot solve? Try here.
wbrussell
Posts: 11
Joined: Thu Apr 27, 2006 3:57 pm

Run .NET Installer Class doesn't work

Postby wbrussell » Thu Jul 23, 2015 2:27 pm

using IA X2 build 4.03.15 on win 7 64-bit

These commands don't work anymore from previous installer:

Run .NET Installer Class $TARGETDIR$\emailroutersvc.exe
Run .NET Uninstaller Class $TARGETDIR$\emailroutersvc.exe

If I comment these out in my code and replace with this it works fine.

Run Program $WINDIR$\Microsoft.NET\Framework\v4.0.30319\InstallUtil.exe "$TARGETDIR$\emailroutersvc.exe"
Run Program $WINDIR$\Microsoft.NET\Framework\v4.0.30319\InstallUtil.exe /u "$TARGETDIR$\emailroutersvc.exe"

Where and how is your installer class getting the path to the installutil.exe?

wbrussell
Posts: 11
Joined: Thu Apr 27, 2006 3:57 pm

Re: Run .NET Installer Class doesn't work

Postby wbrussell » Thu Jul 23, 2015 2:36 pm

This explains why some of my sites (not all), services never install so I have to do a manual call to installutil.exe.

FrancescoT
Site Admin
Posts: 5004
Joined: Sun Aug 22, 2010 4:28 am

Re: Run .NET Installer Class doesn't work

Postby FrancescoT » Fri Jul 24, 2015 11:36 am

Let me check it.

Regards
Francesco Toscano
InstallAware Software

White Papers (HowTos) - http://www.installaware.com/publication ... papers.htm
Publications - http://www.installaware.com/publications-review.htm
InstallAware Help -F1 anywhere in the InstallAware IDE

rodm
Posts: 2
Joined: Tue Sep 01, 2015 5:12 pm

Re: Run .NET Installer Class doesn't work

Postby rodm » Tue Jan 14, 2020 2:48 pm

I have just updated to Installaware X11 and the .net Installer Class function no longer works. Is there any fix for this coming?

FrancescoT
Site Admin
Posts: 5004
Joined: Sun Aug 22, 2010 4:28 am

Re: Run .NET Installer Class doesn't work

Postby FrancescoT » Tue Jan 21, 2020 12:26 pm

rodm wrote:I have just updated to Installaware X11 and the .net Installer Class function no longer works. Is there any fix for this coming?

Run .NET Installer Class doesn't have any problem. The problem here is due some errors present with the setup script.
Francesco Toscano
InstallAware Software

White Papers (HowTos) - http://www.installaware.com/publication ... papers.htm
Publications - http://www.installaware.com/publications-review.htm
InstallAware Help -F1 anywhere in the InstallAware IDE


Return to “Technical Support”

Who is online

Users browsing this forum: Baidu [Spider], Google [Bot] and 10 guests