MS Sql Server settings

Got a problem you cannot solve? Try here.
lansmank
Posts: 13
Joined: Fri May 27, 2005 6:12 pm
Location: Fresno, California
Contact:

MS Sql Server settings

Postby lansmank » Wed Jun 01, 2005 5:15 pm

I'm having an issue making the MS SQL Server plug-in connect to my instance of the MSDE. When connecting to the MSDE, you need to specify [machine name]\\[instance name] in the connection, assuming that you haven't installed the the MSDE as the default instance on the local client. When I specify localhost as the instance of the server, sql doesn't recognize localhost\\instancename as a valid server, neither does it recognize 127.0.0.1\\instancename as a valid server. It needs the machine name as a part of the instance name to establish a connection. My question is, is there a way to specify this in the MS Sql Server plug-in?
Ken Lansman

lansmank
Posts: 13
Joined: Fri May 27, 2005 6:12 pm
Location: Fresno, California
Contact:

Postby lansmank » Wed Jun 01, 2005 6:06 pm

FYI; I found out that you can use (local)\\instancename as a valid connection to a named instance of sql. When i say (local), i mean that in the literal sense, including the opening and closing brackets.

I'm still getting an error when attempting to connect to the instance and run a simple table create script that runs just fine in the Sql Query Analyser. I've got the Create Database option checked, but i'm not getting the database created. Has anyone played with this functionality in InstallAware yet? What needs to happen for the plug-in to successfully create a new database from scratch?
Ken Lansman

sinan
Site Admin
Posts: 974
Joined: Sat Nov 13, 2004 8:12 am
Contact:

Postby sinan » Thu Jun 02, 2005 3:11 am

As long as you have MDAC 2.8 installed, the MS SQL plug-in will work correctly.

lansmank
Posts: 13
Joined: Fri May 27, 2005 6:12 pm
Location: Fresno, California
Contact:

Postby lansmank » Wed Jun 08, 2005 5:44 pm

I posted this finding in another thread, but i thought i would post it here too.

When installing the MSDE, you need to make sure that you start the service prior to attempting to run any scripts against the server. I'm still having an issue with the Control Service command, but i managed to incorporate a quickie work around by running a .bat file with a NET START <Service Name> in it after executing the MSDE setup and prior to executing any sql scripts against the db. Once the service was started, the MS-SQL plugin ran flawlessly.

Hope this helps
Ken Lansman


Return to “Technical Support”

Who is online

Users browsing this forum: No registered users and 14 guests