MSI data base is not refreshing

Got a problem you cannot solve? Try here.
SITL
Posts: 116
Joined: Tue Sep 27, 2016 12:31 am

MSI data base is not refreshing

Postby SITL » Thu May 16, 2019 6:34 am

Dear Francesco,

After two years, i'm back here.
First of all i want to thank Francesco for helping me to create InstallAware project for our product.
It's working fine for all these years.

Now i want to make some changes,
but the problem is, whatever changes i make in the prerequisites region are not visible during installation.
see the the code below. i want to change the messagebox shown if the process is running, that's all.
But my changes are NOT visible after the build.
i mean to say, even after changing the messagebox, i am getting the old message box. so i think my changes in this region are not happening. i have few test messages here, but my test messages(in this while loop) are also not seen during installation.

But i can see the test messages in other places (other regions).

~InstallAware Clipboard Data~
~Wend~
~{DE462E0A-A94D-4CE3-A3F0-523EE9C18DA6}~
~Check Process~
~{A8414242-9FB6-4E7B-82A6-8CC7FFB233AD}~
~Excel.exe~
~RUNNING~
~End~
~{7FDAF326-B3AE-4CFA-AE70-7B8554776BB7}~
~Set Variable~
~{4D1D9F6F-B281-4F1E-A636-DDE3224B12F0}~
~RUNNING$MYAH$MYAH$FALSE~
~FALSE~
~If~
~{C2B48B53-757B-4812-B78F-FB93C181A0DB}~
~PROCESS_CLOSED~
~0~
~IGNORE~
~FALSE~
~End~
~{086EE7E1-5AF7-4B32-AB46-2966D355085A}~
~Terminate Install~
~{52C22D1B-4215-45EE-877B-FF326BAF3DBB}~
~If~
~{F62EC38C-2FA8-4929-91BE-22794DAB58A7}~
~PROCESS_CLOSED~
~0~
~ABORT~
~FALSE~
~End~
~{99BCABF3-7573-4974-8B71-708FB133D348}~
~Terminate Install~
~{B3BB2FDC-F08F-4B34-B7D7-169E30D4FD2B}~
~If~
~{6E63B5D6-7E0E-4963-BCF2-4BC0319C8F13}~
~PROCESS_CLOSED~
~0~
~CANCEL~
~FALSE~
~MessageBox~
~{B71E0AB5-5F33-4F1F-B49D-380F01BB6522}~
~Test message 3~
~Test message 3~
~0~
~1~
~PROCESS_CLOSED~
~MessageBox~
~{BD816D17-E1FB-4F45-A043-A14C13DAD569}~
~Excel Running ! ~
~The Excel is running and it has to be terminated in order to continue ....$NEWLINE$$NEWLINE$Click Abort to stop installer.~
~0~
~0~
~PROCESS_CLOSED~
~While~
~{BCBAF8B2-48AC-49C3-A7BA-58209242372B}~
~RUNNING~
~0~
~TRUE~
~FALSE~
~Comment~
~{5C61C8F8-9BB9-4FED-8E4E-702396516874}~
~~
~Check Process~
~{263FC81F-43A9-4EA5-BA16-CA973218D2DB}~
~Excel.exe~
~RUNNING~
~Comment~
~{14DF138A-2444-4A23-82B7-3A61162CB845}~
~Check if the Excel is running~

Appreciate your help.
Regards
SITL

SITL
Posts: 116
Joined: Tue Sep 27, 2016 12:31 am

change prerequisites

Postby SITL » Thu Jun 06, 2019 2:00 am

Hi,
I want to make some changes in the prerequisites region.
But the problem is, whatever changes i make in the prerequisites region are not visible during installation.
i just want to change the messagebox shown if a particular the process is running, that's all.
i.e., instead of OK and CANCEL buttons, i want to have OK, CANCEL and Abort buttons in the message box.
Actually i made that change, it's building fine.
But my changes are NOT visible after the build.
i mean to say, even after changing the messagebox, i am getting the old message box. so i think my changes in this region are not happening.
But i can see the test messages in other places (other regions).

Appreciate your help.
Regards
SITL


Return to “Technical Support”

Who is online

Users browsing this forum: No registered users and 14 guests