multiple mia*.tmp folders in %programdata% folder

Got a problem you cannot solve? Try here.
Sheri_Steeves
Posts: 124
Joined: Mon Oct 22, 2012 2:14 pm

Re: multiple mia*.tmp folders in %programdata% folder

Postby Sheri_Steeves » Thu Nov 23, 2023 4:28 pm

This matter was brought back to my attention today and I've determined at least one case where it happens every time.

If I reboot the computer at the end of the installation (SUCCESS=REBOOT, REBOOTCOMPUTER=TRUE), then that folder gets left behind.

I reproduced this with a very simple wizard-generated install that does nothing but install a text file and set the reboot flag at the end of the install. I see the exact same behavior as my install. I used this generic install for all further testing below.

From my testing, it seems to be a timing issue between the computer restarting and IA cleaning up.
If "Reboot Computer" is checked, and no other windows or apps are open, the restart happens immediately and the folder is left behind every time.

If I had "Reboot Computer" checked, but also had an application open that would pause the restart with the "You have open apps, restart anyway/cancel, sometimes the folder would get cleared, and sometimes it would still be there.

Thinking it was a speed/timing issue, I repeated this test with Notepad open on an edited file on my desktop (not part of the install) so I would get the open app prompt, waiting about 5 seconds before saying restart anyway. When I waited, the folder was always cleaned up.

I also tried the NATIVE_HARDLINKS variable; my install and the test install are not using the NATIVE_ENGINE so this made no difference for me.

Is there a flag I'm missing here? Is there a way for IA to wait before issuing the reboot? Or to mark that folder for deletion on restart?

I've included my test install to demonstrate the issue.
Attachments
TestReboot.zip
(5.95 MiB) Downloaded 75 times


Return to “Technical Support”

Who is online

Users browsing this forum: No registered users and 25 guests