.NET Framework 2.0 unrecognized by existing apps

Got a problem you cannot solve? Try here.
gandalf24
Posts: 3
Joined: Sun Nov 27, 2005 6:43 pm

.NET Framework 2.0 unrecognized by existing apps

Postby gandalf24 » Sun Nov 27, 2005 6:52 pm

After using InstallAware to install our program on a clean machine (straight out of the box), it installed the 2.0 framework, but our program failed to recognize that the 2.0 framework was installed. It (the 2.0 Framework) also failed to appear in Administrative tools section of Control Panel. The 2.0 Framework did show up in the Add/Remove programs section of Control Panel.

2nd issue - if we try to install some dll's that we compiled with strong name into the GAC, we get an error from the InstallAware compiler that says it does not have a strong name. Also, we cannot use the visual tool to add the files into the GAC (they fail to obtain version information, etc)

Any help would be appreciated.

sinan
Site Admin
Posts: 987
Joined: Sat Nov 13, 2004 8:12 am
Contact:

Postby sinan » Sun Nov 27, 2005 7:04 pm

For the first problem, do you have the opportunity to test the situation in a clean machine and consistently reproduce it?

And as for the second, can you upload one of those assemblies, so we can try to reproduce the issue here?

gandalf24
Posts: 3
Joined: Sun Nov 27, 2005 6:43 pm

MSIL Processor Architecture

Postby gandalf24 » Mon Nov 28, 2005 11:57 am

The Assemblies that will not load have the MSIL processor architecture assigned to them. If the processor architecture is blank, they will install OK. If you still need an example of a dll, I can send you one.

sinan
Site Admin
Posts: 987
Joined: Sat Nov 13, 2004 8:12 am
Contact:

Postby sinan » Mon Nov 28, 2005 12:14 pm

Yes, please. Thank you.

gandalf24
Posts: 3
Joined: Sun Nov 27, 2005 6:43 pm

Assemblies Compiled with 2.0 Framework won't load GAC

Postby gandalf24 » Tue Nov 29, 2005 7:12 pm

It appears that any assemblies compiled with the 2.0 Framework will not load into the GAC. We are able to manually add them to the GAC using Framework 2.0 configuration utility, so it is not a problem with the dll's. We are getting the following error: Unable to get assembly information for name.dll. I will attach a single dll here as an example.

File Attached:

sinan
Site Admin
Posts: 987
Joined: Sat Nov 13, 2004 8:12 am
Contact:

Postby sinan » Tue Nov 29, 2005 8:23 pm

Thank you for reporting this problem. It appears InstallAware could not handle .NET 2.0 assemblies during the "obtain assembly information" phase.

Please extract the contents of the attached archive into your InstallAware folder, overwriting old copies of files. Remove any assemblies you may have added to the assembly view, then add them again - it will work now.

Thanks again for reporting this bug!

File Attached:

<a href="files/112920051923/mGacInfoX.zip">mGacInfoX.zip


Return to “Technical Support”

Who is online

Users browsing this forum: No registered users and 14 guests